Exp build:ios incorrectly creating info.plist


I’ve tried four times to build my app and it keeps coming back with an old build number. I verified this by uncompressing the IPA file and looking into Info.plist.

An example of these four builds is this one: https://expo.io/builds/7b1ba37c-b5c9-4f76-a080-a2a7baeb93da

I don’t know why it’s not reading my exp.json correctly. I tried renaming it to app.json and then expo said it couldnt find it. Very strange. I’d be appreciative of any input as maybe I’m doing something wrong.

Here’s my exp.json

   "name": "iVeteran",
   "icon": "./res/img/ivet-seal-512.png",
   "version": "2.0.3",
   "slug": "iveteran",
   "sdkVersion": "19.0.0",
   "orientation": "portrait",
   "androidStatusBar": {
      "barStyle": "light-content",
      "backgroundColor": "#171717"
   "loading": {
     "icon": "./res/img/ivet-seal-512.png",
     "backgroundColor": "#171717",
     "hideExponentText": true
   "ios": {
     "bundleIdentifier": "com.iveteran.mobile",
     "buildNumber" : "37",
     "supportsTablet": true
   "android": {
     "package": "com.iveteran.mobile",
     "versionCode": 37
   "scheme": "ivet"

UPDATE: I tried unzipping the IPA, changing the build number manually, then rezipping it and uploading it as an ipa via fastlane and now I get something else wrong with the package:

"Missing Provisioning Profile - Apps must contain a provisioning profile in a file named embedded.mobileprovision."

I really need to be able to release, please help :frowning:

hi i have the same problem, you have to publish your app on expo before building it

how do you publish your app on expo?

just click on “publish” on your expo XDE

or exp publish with exp cli

I’ve actually never used XDE, but exp publish works, thanks!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.