[exp] Android: Build in progress... (after 12h)

Last night I run a exp build:android
Today, I still get

[exp] Your project looks good!
[exp] Checking if current build exists...

[exp] ============
[exp] Build Status
[exp] ============

[exp] Android: Build in progress...

Already updated the exp client.
And already tried to start a new build
Still I get:

[exp] Android: Build in progress...
[exp] Cannot start new build, as there is a build in progress.

Account miredefamilia

I have the same issues with ios build
It is taking around 24 hrs and still in progress

Build ID: 04b14ad1-5190-47e6-b041-98aabd631ed2

Hi folks, I will look up these jobs for you. Thank you for your patience.


@alriyami I killed your job, can run again now

@hudsonmendes Yours is cleared as well

Thanks, Edgar.
Would there be anywhere we could contribute to in order to improve this?
Any open-source commit that we could make to give you guys a hand and make it better?


That’s super appreciated but I am not sure if this part of code is open source, mostly cause it has lots of credentials to use, etc.

But I just studied this part of the codebase, so things in improve in time as we improve the building of mobile apps.

Thanks for the hard work!


Thanks, problem solved

(Apologies if I am posting in the wrong place - I am new to the community :slight_smile: )
Thanks so much for creating and maintaining these fantastic tools (expo, exp, snack)!

But I had encountered the same problem of a build stuck at the “build started” status.
Not sure how can I get the build id but my app name is heySimonGame (version is 0.5.0 if this helps).

what is your expo username?

I think it is “Hey”.

same problem its my ID 90e2481c-0bee-482d-992f-d58ce910de43

same problem, still in progress after 24 hours.

Build ID: 0858aa9b-0f86-4666-a5fc-9e2d137645e7

i think i should have replied instead of posting a new message so that you would be notified :slight_smile:
but yea my expo username should be “Hey”.

And the build is still stuck (for 6 days) - i guess it would be great if we have some diagnostic information or the ability to clear our own build so that it can relieve the moderators’ burden

Sorry about that @hey, I went ahead and killed it, try again please.

Re diagnostic info, ya, I agree, we’re working on it to be better

1 Like

No worries. :slight_smile:
And FYI it worked at the second try.

Cool that would be great!

1 Like

Having same problem with Build ID 08177977-2b3d-4a5d-9920-05453137a9a6

Hi I’m having a very similar issue today building my app for IOS

The first time the build was queued long time and then aborted

13:46:19 [exp] Building…
13:46:20 [exp] Build started, it may take a few minutes to complete.
13:46:20 [exp] You can monitor the build at https://expo.io/builds/1f9ffde0-cc76-4b2b-ae72-c14d838fdec9|
13:46:20 [exp] Waiting for build to complete. You can press Ctrl+C to exit./
14:07:49 [exp] Timeout reached! Project is taking longer than expected to finish building, aborting wait…

If I try to build again now i get

14:11:11 [exp] Making sure project is set up correctly…
14:11:17 [exp] Your project looks good!
14:11:18 [exp] Checking if current build exists…14:11:19 [exp] =================
14:11:19 [exp] Builds Statuses
14:11:19 [exp] =================
14:11:19 [exp] ### 0 | iOS | https://expo.io/builds/1f9ffde0-cc76-4b2b-ae72-c14d838fdec9 ###
14:11:19 [exp] Build waiting in queue…
14:11:19 [exp] Cannot start new build, as there is a build in progress.

Is there any ongoing known issue with builds today?

Having the same issue you can check out the status here

Apparently they are having some issues with the iOS builds