Exo Build Android (Node Environment)

How can I update the Node Environment on Expo Build

Running yarn in the root dir of your repository 
yarn install v1.22.10
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@2.3.2: The platform "linux" is incompatible with this module.
info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
[stderr] error eslint@8.3.0: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "14.15.1"
[stderr] error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
yarn exited with non-zero code: 1

I ran into this Issue when trying to build online

There is node field in eas.json build profile where you can specify node version

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.