error with last expo client and sdk32

yesterday i have updated the last expo client on android and when i open my app with sdk version 32 i get this error: uncaught error: backgroundColor

1 Like

The same for me!
This message is very unclear, I made sure to revert the changes I made to a version of the code I’m sure worked before the client update.

Here’s a screenshot.

Are more people encountering this problem?

was a background property with transparent. i have resolved leaving transparent and give a color. is strange that in the last client version with sdk32 transparent work. with the last update of the client with the sdk 32 i have got this error. the problem is the debugging. you must isolate any element of the view that open the app for understand where is the problem. try to search backgroundColor transparent and put a normal color

Thanks that worked! :slight_smile:
Very unclear error message still…

1 Like

I am getting same error but i do not have any backgroundColor : transparent

Surely the solution isn’t just “abandon transparency” right? Is there some fix that allows us to keep transparency? Is there a new client?

It seems like some transparency works in some places and maybe not in others? Anyone know what the deal is?

Had the same issue but caused by a native-base button with both prop primary and transparent set and removing primary solved it and transparent works again :slight_smile:

This seems to be an issue in the client on Android, and an inconsistent one at that. Builds for devices are still working, and the client on iOS is fine.

Anyone have any good suggestions for troubleshooting debugging?

Any chance that an updated client is coming?

Temporary solution backgroundColor: ‘rgba(0,0,0,0)’

There is not much discussion out there about this, so is this issue new?
I am stopped by this issue, and disabled all codes related to backgroundColor: ‘transparent’.
To no avail. Does the admins knew about this report?

yes my problem was with nativebase button

Finally found the solution to this issue for my app. The issue was that we had some native-base buttons where we were styling with backgroundColor: null. Switching these to backgroundColor: ‘transparent’ got this working on the latest expo client.

Something that helped us while we worked around this issue was being able to install the previous version of the expo client. The links that were provided to me for that were:



Also, there is an open issue for this on GitHub here: