Error with AuthSession on Expo Go since I changed my user to an organization

Please provide the following:

  1. SDK Version: 46.0.9
  2. Platforms(Android/iOS/web/all): Android / iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

I recently changed my username into an organization in Expo. Ever since I did it, if I try to run the app in development, in Expo Go, I get an error that reads:
ExceptionsManager.js:149 Error: Cannot use the AuthSession proxy because the project full name is not defined. Prefer AuthRequest (with the useProxy option set to false) in combination with an Expo Development Client build of your application. To continue using the AuthSession proxy, specify the project full name (@owner/slug) using the projectNameForProxy option.

If I run npx expo config --type public, I correctly get currentFullName and originalFullName to have ‘(at)owner/slug’. My app.json also contains “owner”: “myOrg”. I’ve noticed that if I manually add currentFullName and originalFullName to my app.json, the app starts working again… But obviously that’s not ideal.

I’ve also tried adding promptAsync({projectNameForProxy: ‘(at)owner/slug’, useProxy: true} but it doesn’t seem to do anything.

Any ideas? Thanks!

I’m noticing that this is failing because SessionUrlProvider in expo-auth-session is looking for Constants.expoConfig.originalFullName and my Constants.expoConfig doesn’t have that attribute, although I’ve no idea how one would go about fixing that.