Error when upload to Google Play Store


I am trying out eas and wanted to upload the Android build in the Google Play Store.
When I run eas build I get the following error:
“Google Api Error: forbidden: Release artifacts require permissions that are missing from permission declaration.”
My permissions in app.json are: “permissions”: [“ACCESS_BACKGROUND_LOCATION”, “ACCESS_FINE_LOCATION”, “ACCESS_COARSE_LOCATION”]
I’ve tried also just “LOCATION”, just “ACCESS_BACKGROUND_LOCATION” and just “ACCESS_COARSE_LOCATION” and I got the same error.
Also, my app was deleted from the store because of the Location permissions.

Can anyone help with this? Or with a suggestion about what am I doing wrong?

Thank you!

I experienced a similar issue. When I uploaded a EAS android build, it got an error saying that my release was requiring the CAMERA permission, when my permissions were set to [“ACCESS_FINE_LOCATION”, “ACCESS_COARSE_LOCATION”].

When I build with expo build:android, this error didn’t occur. There seems to be an issue with how EAS build handles android permissions

please refer to this: Android app rejected because of background location · Issue #11918 · expo/expo · GitHub

@jackgww - eas build for managed apps is not production ready yet - i recommend using expo build:android for your production apps for now. we will have the issue you’re seeing now resolved soon when we launch managed support preview.