Error when trying to publish project

I keep getting this error when trying to publish my Expo project:


I have no idea why, anyone know?

Try this: Error: connect ECONNREFUSED

Also maybe: "Connection Refused" error during exp build

also this:

How would I do that? I can’t seem to find it in the code.

It’s a hidden directory in the root of the project:

yourapp$ ls -al
total 512
drwxr-xr-x   14 michael  wheel     448 Dec  9 21:07 .
drwxrwxrwt   13 root     wheel     416 Dec  9 21:06 ..
-rw-r--r--    1 michael  wheel    6148 Oct 26  1985 .DS_Store
drwxr-xr-x    4 michael  wheel     128 Dec  9 21:08 .expo
drwxr-xr-x    3 michael  wheel      96 Dec  9 21:06 .expo-shared
drwxr-xr-x    9 michael  wheel     288 Dec  9 21:07 .git
-rw-r--r--    1 michael  wheel     130 Oct 26  1985 .gitignore
-rw-r--r--    1 michael  wheel     403 Oct 26  1985 App.js
-rw-r--r--    1 michael  wheel     551 Dec  9 21:06 app.json
drwxr-xr-x    4 michael  wheel     128 Dec  9 21:06 assets
-rw-r--r--    1 michael  wheel     107 Oct 26  1985 babel.config.js
drwxr-xr-x  524 michael  wheel   16768 Dec  9 21:06 node_modules
-rw-r--r--    1 michael  wheel     519 Dec  9 21:06 package.json
-rw-r--r--    1 michael  wheel  231605 Dec  9 21:06 yarn.lock

One way to remove it would be:

yourapp$ rm -r .expo

Thank you everyone for your help, but unfortunately none of these solutions have worked.

@wodin - when I remove the .expo folder manually in VS Code, when running expo build:android it re-adds it again with no solution (I gave up on the expo publish for the last project and started a new one and copied the code, so that’s working now).

Have I done something wrong or is this just unnecessarily hard?

Glad you got it working.

The .expo directory is automatically created, so that’s expected.

It doesn’t sound like you’ve done anything wrong, and it should not be so hard. Unfortunately it’s very difficult to debug something like this by proxy :slight_smile:

So, is that it? No solution, I just have to try and figure it out myself? I hate to sound harsh like this, but I’ve built an entire app on Expo and don’t plan to re-build it on another service. Is there anything else that I could be doing wrong? Is there no other way to turn a published project into an .APK or .IPA file?

I literally don’t know what happened…BUT IT WORKED!! I think it might have been the new expo-cli update, 3.11.3. Thanks for your help everyone, if I have anymore problems I will let you guys know.

1 Like

After weeks of troubleshooting, I have found out a solution. Here it is:

Before building your project, PUBLISH IT first. If not, you will continue to get the connect ECONNREFUSED error.

Thanks to @fanofskynyrd & @wodin for all your help!

EDIT: This doesn’t work, seems like the real solution was this:

1 Like


I’m glad you got it working, but when you expo build:... it automatically publishes as well, unless you specifically tell it not to with the --no-publish option. So I still don’t understand the cause of problem.

Once again, after more troubleshooting, seems like it was a different issue. I think that you have to have the project open (using expo start) then, in a new window, run expo build.

1 Like

If you have expo start running when trying to publish then the expo publish command will connect to the already-running bundler. If you do not run expo start in another window first then expo publish is supposed to start the bundler automatically.

So it seems that in your case expo publish was not able to do that successfully for some reason.

Anyway, running expo start in a separate window is completely fine.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.