Error when installing firebase with blank managed workflow template

I’m trying to install firebase as per Using Firebase - Expo Documentation .

I’m starting out with a blank managed workflow template and nothing else.

Subsequently, I’m running:

expo install firebase

The errors I receive at the end are:

z.vcxproj -> C:\jsdev\rntest3\node_modules\grpc\build\Release\\libz.lib
gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\Microsoft Visual Studio\2017\Build
Tools\MSBuild\15.0\Bin\MSBuild.exe` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\
gyp ERR! stack     at ChildProcess.emit (events.js:315:20)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_proces
gyp ERR! System Windows_NT 6.3.9600
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodej
s\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "build" "--fallb
ack-to-build" "--library=static_library" "--module=C:\\jsdev\\rntest3\\node_modu
de" "--module_name=grpc_node" "--module_path=C:\\jsdev\\rntest3\\node_modules\\g
rpc\\src\\node\\extension_binary\\node-v83-win32-x64-unknown" "--napi_version=7"
"--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v83"
gyp ERR! cwd C:\jsdev\rntest3\node_modules\grpc
gyp ERR! node -v v14.15.4
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute 'C:\Program Files\nodejs\node.e
xe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.j
s build --fallback-to-build --library=static_library --module=C:\jsdev\rntest3\n
node --module_name=grpc_node --module_path=C:\jsdev\rntest3\node_modules\grpc\sr
c\node\extension_binary\node-v83-win32-x64-unknown --napi_version=7 --node_abi_n
api=napi --napi_build_version=0 --node_napi_label=node-v83' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (C:\jsdev\rntest3\node_m
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:315:20)
Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node
_modules\npm\node_modules\node-gyp\bin\node-gyp.js build --fallback-to-build --l
ibrary=static_library --module=C:\jsdev\rntest3\node_modules\grpc\src\node\exten
sion_binary\node-v83-win32-x64-unknown\grpc_node.node --module_name=grpc_node --
3-win32-x64-unknown --napi_version=7 --node_abi_napi=napi --napi_build_version=0
--node_napi_label=node-v83' (1)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:1048:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/chi
node-pre-gyp ERR! System Windows_NT 6.3.9600
node-pre-gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\jsdev\\rnte
st3\\node_modules\\grpc\\node_modules\\node-pre-gyp\\bin\\node-pre-gyp" "install
" "--fallback-to-build" "--library=static_library"
node-pre-gyp ERR! cwd C:\jsdev\rntest3\node_modules\grpc
node-pre-gyp ERR! node -v v14.15.4
node-pre-gyp ERR! node-pre-gyp -v v0.14.0
node-pre-gyp ERR! not ok
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules\je
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"

npm ERR! errno 1
npm ERR! grpc@1.24.2 install: `node-pre-gyp install --fallback-to-build --librar
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the grpc@1.24.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional log
ging output above.

I tried this again on a separate instance where I added the latest versions of grpc and npm-gyp as dependencies, but this resulted in a similar error.

Interestingly enough, installing a newer version of firebase (for example 8.2.2) worked well. Unfortunately, there seems to have been a compatibility issue with that version.

Also, I have freshly installed Windows build tools, but it did not help. I have the latest version of npm.

Any ideas on what could be going wrong?

hi there. if you read the log output you can see that it’s failing to compile a dependency gprc. if you google that you will see more info about what is happening. you can switch to a node version where a prebuilt binary of grpc is available, or you can install required dependencies to be able to compile it. sadly firebase depends on this package that has native dependencies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.