Error - undefined is not an object

I am facing this error since the last 2 days. Below are the specifications reqd:
expo diagnostics

Expo CLI 3.11.7 environment info:
OS: macOS 10.15.2
Shell: 3.2.57 - /bin/bash
Node: 10.13.0 - /usr/local/bin/node
Yarn: 1.12.3 - /usr/local/bin/yarn
npm: 6.4.1 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Xcode: 11.3/11C29 - /usr/bin/xcodebuild
expo-cli: 3.11.7

I have tried every solution that may be close to this, however, the project is still not starting up. The error occurs after bundles are done on the project.
I have not used prop types anywhere in the project, though I am not sure about the modules & their dependencies.
I am getting this error after updating the expo-cli to 3.11.7.
The expo project width 35sdk, expo project with 36 sdk, expo project detached to expokit are not working, however the detached one to bare workflow somehow is still working.

I have tried reinstalling expo-cli, cache cleaning of the npm, expo project.
still can’t find any solution.

need help on this.


Are you using Animated.createAnimatedComponent()? If so, how are you calling it? It seems the code is expecting a component as the only argument to createAnimatedComponent() and it’s trying to reference this component’s propTypes, but it looks to me like this will only fail if you don’t pass a component in to the createAnimatedComponent() function (or pass in something that’s undefined).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.