Error: undefined is not a function (evaluating 'Object.getOwnPropertySymbols(object)'

Looking to potentially use Expo for a project but I am running into an error running the example application that includes multiple screens.

When I click to go to a new screen I get this error

I am on macos

Node v6.11.0

Hey, we’ve reproduced this error and are looking into it. Sorry for the inconvenience! Will update about fix / potential workarounds.



Here is what I tried so far to no success:

  • Tried node 4.8.3 & 6.11.0
  • Tried installing deps using yarn
  • Updating package.json to use the main repo instead of expo’s fork

Hi @boiled_dev! Can you do npm install expo@18.0.2 --save in your project directory and try again? That should resolve the problem. This was the first few hours since our release went out into the wild and there was a function being used in some cases that doesn’t exist on Android because the JS runtime is older, so I polyfilled it. Let me know if that fixes it!


Your fix does seem to work!

However, I did get this in the output: UNMET PEER DEPENDENCY react@>=15.3.1

unfortunately that’s just the state of the world right now, re: peer dependencies! the react-native dependency on react is 16.0.0-alpha, which according to npm is not >= 15.3.1 (i strongly believe that it should be – see this issue on the npm repository for more information). accordingly, we have to see these warnings everytime we install something until we move off of react 16 alpha. fwiw, 100% of runs react 16 alpha.

1 Like

(yarn treats these peerDependencies differently, in a much more intuitive way, and so you won’t get warnings if you use yarn, see:

1 Like

Excellent. Thanks for all you help and looking into this!

no problem! thanks for reporting it and verifying the fix :slight_smile:

1 Like

Can I get help with this?

hello @supriyakalghatgi – set your sdkVersion to 18.0.0 in app.json – minor/patch versions are only relevant to “expo” in package.json