Error to run App after upgrading to SDK 47 from 40

Please provide the following:

  1. SDK Version: 47
  2. Platforms(Android/iOS/web/all): Android

So I had an app that running perfectly in SDK 40, Then I got a notice from Google that they are changing the policy and it requires me to change some packages in my app, so I upgraded the SDK from 40 to 47, but now whenever I try to run the code after installing all the required packages I am getting the error:

“Could not get BatchedBridge, make sure your bundle is packaged correctly”

I tried to see some other from the app but I couldn’t get any other logs,
When I am trying to run expo run:android I get the following error:

`Script ‘…\node_modules\expo-modules-autolinking\scripts\android\autolinking_implementation.gradle’ line: 272

  • What went wrong:
    A problem occurred evaluating project ‘:expo’.

A problem occurred configuring project ‘:expo-modules-core’.
Failed to notify project evaluation listener.
SDK location not found. Define a valid SDK location with an ANDROID_HOME environment variable or by setting the sdk.dir path in your project’s local properties file at


Could not get unknown property ‘release’ for SoftwareComponentInternal set of type org.gradle.api.internal.component.DefaultSoftwareComponentContainer.`

I runned expo doctor --fix-dependencies and it find no problems/

I runned expo update and it did update some expo packages.

I tried to run it also in Iphone and I still get the same error “Could not…”

I think there is an other issue with the packages but I the error is hidden behind the “Could not…”

I am clueless, If you have anything I can do in order to fix it?
Thanks in advance

Current node version: 16.16
Tried version: 16.13/17/18

what is your node version?
change to 16.13.0, it may work

I tried the entire process from expo update as well is just run the app, still not working.
What was it suppose to fix?

yea sometimes the node version doesn’t fit the newest expo versions, e.g, i wasn’t able to make http requisitions using node 18.12 with my app with Expo at v46.0.9. i fixed it swapping my node to 16.13.

actually your topic made me wonder if is worth building a app with expo cause of the trouble on maintaining it…

Hi @spectorhacked

It is generally best to upgrade one SDK version at a time instead of all at once.
Also, for each one you should read through the release blog post for all breaking changes. If any of these are relevant to your app you will need to fix them.
Unfortunately, upgrading from such an old SDK version is more tricky because current versions of Expo Go no longer support such an old SDK version, but you can create a preview or development build with EAS Build.
When you have SDK 41 working you can do expo-cli upgrade 42 and read the blog post to find and fix any breaking changes from that version.

@civitao, while problems like this can be frustrating, upgrading Expo apps are a lot easier than upgrading plain React Native apps because you don’t need to worry about changes to the native projects

1 Like

you’re right @wodin

I am reverted back to the previous SDK (40) and when I am am trying to upgrade to expo SDK 41

So in my case my the errors occurred because I used “npm install” instead of using the expo cli,
when I used “npx expo install” the expo handled the dependencies conflicts.

Now I am using npx expo doctor to fix the conflicts.

This was the error in my case if anyone encounter it in the future, thanks for the support @wodin and @civitao


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.