Error running adb: Error running app. Error: Activity not started, unable to resolve Intent

Hi I am trying to run ‘yarn android’ on my react-native project. And am running into the following error:

    yarn android v0.27.5
    $ react-native-scripts android
    10:37:45 AM: Starting packager...
    10:39:34 AM: Starting Android...
    10:39:37 AM: Packager started!
    To view your app with live reloading, point the Expo app to this QR code.
    You'll find the QR scanner on the Projects tab of the app.
        <QR CODE>                                                  
    Or enter this address in the Expo app's search bar:
    Your phone will need to be on the same local network as this computer.
    For links to install the Expo app, please visit
        Logs from serving your app will appear here. Press Ctrl+C at any time to stop.
    Error running adb: Error running app. Error: Activity not started, unable to resolve Intent { act=android.intent.action.VIEW dat=exp:// flg=0x10000000 }
    (node:28009) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): TypeError: Cannot read property 'length' of null

I also tried running ‘npm start’ and then ‘a’ for the android option but had the same error.

I used the create-react-native-app generator to setup my app and here is my project structure:

    App.js			app.json		gen			package.json
    App.test.js		assets			my-app-key.keystore	stylesheet.js		components		node_modules		yarn.lock

I also tried scanning the qr code with my expo app to run my app on my phone but it goes to 100% and then crashes out of the app, or it gives the dark blue screen in which the error is “Uncaught Error” Packager is not running at http::19003" (even if the port I scan is http:19000).

Can anyone help me with this issue?

I also just got this error when trying to run it on the expo app on my device:

 [sane] Warning: Lost connection to watchman, reconnecting..
/Users/minimoe/Library/LaunchAgents/com.github.facebook.watchman.plist: service already loaded

Update here is the link when I run “exp diagnostics”

I suspect the problem is coming from TypeError: Cannot read property 'length' of null
Which means somewhere inside a promise X.length is trying to be accessed with X is null.

If you can reproduce on we might be able to find the issue.

not sure what it was exactly, but I git reverted to an old version and it worked, I guess it was something wrong in the code. Though I wish the error would have highlighted which page or line to refer to as my repository is quite lengthy

make sure you are using minimal API 19 on your emulator, its work on me somehow.

1 Like

I uninstalled the app on the Android Emulator and and used the “Run on Android device/emulator” from the Metro Bundler on http://localhost:19002/to fix it for me.