error on ios build - Cannot read PKCS#12 PFX

Hi there,
When I run expo build:ios I’m getting the following error when Expo tries to retrieve any existing Apple Distribution Certificates:

Cannot read PKCS#12 PFX. ASN.1 object is not an PKCS#12 PFX.

06

I’m using Expo v2.18.4

Anyone else getting this error as well?

I was able to get around this issue by manually creating the P12 distribution certs and pointing to them instead of having Expo create them for me. The other certs (provisioning profile and push notification cert) were created automatically by Expo successfully.

Hey @oldo, glad you found a workaround, but I’m curious if clearing the credentials (by passing the -c flag to clear all creds, or --clear-dist-cert just for the distribution certifcate) would have fixed it, that way you don’t have to manually create it

Hi @charliecruzan
Thanks for the suggestion but yes I had tried that and it wasn’t making a difference.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.