ERROR: Node.js version 9.7.1 is no longer supported

Please run expo diagnostics and paste the log that’s printed out along with your question or issue!

If I run expo start on a project that I was able to run a year ago, I see this:

ERROR: Node.js version 9.7.1 is no longer supported.

expo-cli supports following Node.js versions:
* >=8.9.0 <9.0.0 (Maintenance LTS)
* >=10.13.0 <11.0.0 (Active LTS)
* >=12.0.0 (Current Release)

I downloaded and installed the node version that I found on Expo website (version 13.3.0) but if I run node --version I still see the old one: v9.7.1

How could I solve this?

If I run expo diagnostics I see the same output as above so I cannot paste it

It seems you have both versions of node installed. You’ll need to find the old version and uninstall/remove it or otherwise put the newer version first in your PATH environment variable.

You don’t say what operating system you’re running. If you’re running macOS, try opening a Terminal and typing:

$ which node

That should tell you where to look.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.