Error(No architectures in the bindary. Lipo failed...) while sending app to appstore after upgrade to SDK 39

After upgrade to SDK 39, I get the error “No architectures in the bindary. Lipo failed to detect any architectures in the bundle executable” when sending to appstore via “Transporter”.

I need to fix it asap and I will be glad for any help.

expo diagnostics:
Expo CLI 3.27.13 environment info:
OS: Linux 5.8 Kali GNU/Linux Rolling 2020.3
Shell: 5.0.18 - /bin/bash
Node: 12.18.4 - /usr/bin/node
npm: 6.14.8 - /usr/bin/npm
expo: ^39.0.0 => 39.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.7 => 0.13.14
react-navigation: ^4.0.10 => 4.4.2
expo-cli: 3.27.13
Expo Workflow: managed

Hey @moveax,

In the past this issue was resolved by the user needing to download or update Xcode on their system but it appears you’re on Linux. Has this worked for you before? AFAIK one needs to be granted special privileges to use Transporter on Windows or Linux and you may be the first Expo user to have used this special workflow (and reported an issue about it)


hi @adamjnav

I work and compile on linux then send it to my colleague which works on mac which sends it to appstore via Transporter. All time everything was good but after upgrade we have this issue

I have the same problem here. I use expo on Windows 10. I use the Managed Workflow and when building the “ipa” file, Transporter blocks it saying it has no architectures in the binary. It could be a problem with the automated build on Expo servers…

hi bro. Install Xcode on the mac which from you send builds, this worked for us

Thank you a lot! We already installed it here and it worked! :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.