Error in versions of Stripe and ExpoKit ios

Hi, hoping someone could help me with this versioning problem:

I’m using expoKit and Stripe for payments, whit android I have no problem but with ios I got the following:

[!] CocoaPods could not find compatible versions for pod "Stripe":
  In snapshot (Podfile.lock):
    Stripe (= 13.0.3, ~> 13.0.3)

  In Podfile:
    EXPaymentsStripe (from `../node_modules/expo-payments-stripe/ios`) was resolved to 1.0.1, which depends on
      Stripe (~> 13.0.3)

    ExpoKit/Payments (from ``, tag `ios/2.8.4`) was resolved to 2.8.4, which depends on
      Stripe (~> 10.1.0)

It seems like you've changed the constraints of dependency `Stripe` inside your development pod `EXPaymentsStripe`.
You should run `pod update Stripe` to apply changes you've made.

My Podfile is:

target 'myapp' do
  pod 'Stripe', '~> 13.0.3'
  pod 'ExpoKit',
    :git => "",
    :tag => "ios/2.8.4",
    :subspecs => [
    :inhibit_warnings => true


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.