Error in building process for android


I have successfully created an app with expo and published it on the android play store.

Now, I would like to update it.

The first time, I gave it a version number of 1.0.0. But everytime I upload my apk to the play store I get this error.

You must use another APK file, because your file is already at code version 1.

I tried to change the version with no success. I tried to add the versionCode to the android config in the app.json with an error while building.

$ exp build:status
[exp] Making sure project is set up correctly...
-[exp] Warning: Problem validating fields in app.json. See                                                                                                                                                                                               versions/v20.0.0/guides/configuration.html.
[exp]  • should be integer.
[exp] Your project looks good!
[exp] Checking if current build exists...

[exp] ============
[exp] Build Status
[exp] ============

[exp] Android: There was an error with this build.

Here is my app.json

  "expo": {
    "name": "Elise et Antoine - quizz",
    "description": "Petit quizz pour notre mariage",
    "slug": "eeta",
    "privacy": "public",
    "sdkVersion": "20.0.0",
    "version": "2.0.0",
    "orientation": "portrait",
    "primaryColor": "#cccccc",
    "icon": "./assets/icons/app-icon.png",
    "loading": {
      "icon": "./assets/icons/loading-icon.png",
      "hideExponentText": true
    "packagerOpts": {
      "assetExts": ["ttf", "mp4"]
    "ios": {
      "supportsTablet": true
    "android": {
      "versionCode" : "2.0.0",
      "package": "com.hyptos.eeta"

Thanks you for your time, any help would be appreciated.

I’m stupid. versionCode must be an integer.

yay \o/ …

can you give an example how your specifying the versionCode for android ?

In your app.json:

  "expo": {
     "android": {
         "versionCode": 1

Make sure it’s unquoted (i.e. not “1” ). My mistake was leaving it quoted.