Error getting message that device is not registered when using expo-server-sdk

Please provide the following:

  1. SDK Version: 44
  2. Platforms(Android/iOS):
  3. Package:
    • expo-server-sdk: ^3.6.0
    • expo-notifications: ~0.13.3

I building standalone app to the feature notification according to the document below:

  1. Notifications - Expo Documentation
  2. GitHub - expo/expo-server-sdk-node: Server-side library for working with Expo using Node.js

All the worked on debug mode with server (expo-server-sdk) and expo push token.
The problem is this not to work when build standalone app. I change expo push token to device token but receive message:

I change the firebase cloud messaging usage mode send test message on this device successfully received.

Have any of you encountered the same situation as me?
Please show me another way to fix it. Thank you very much !

Hey @devfsoft06, if you are still using expo-server-sdk to send the push notifications you still want to use the Expo push token rather than the device token value.

The device token is to be used when you no longer using the Expo server to send your notifications.

Cheers,
Adam

1 Like

Thanks you very much. After I changed to Expo token it worked.
Have a nice day !