Error: EPERM: operation not permitted, scandir 'C:\Config.Msi'

I’ve been trying to do an EAS build but I keep getting this error

I have tried clearing my cache, uninstalling node and reinstalling it. Creating a new app entirely and moving the source code and dependencies over. installing Expo 45. downgraded to expo 44.

EAS diagnostics

  EAS CLI 0.52.0 environment info:
      OS: Windows 10 10.0.19043
      Node: 16.15.0 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.22.4 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
      npm: 8.10.0 - C:\Program Files\nodejs\npm.CMD
      Git: 2.33.0.
      expo: ^44.0.0 => 44.0.6
      expo-updates: ~0.11.7 => 0.11.7
      react: 17.0.1 => 17.0.1
      react-dom: 17.0.1 => 17.0.1
      react-native: 0.64.3 => 0.64.3
      react-native-web: 0.17.1 => 0.17.1
    Error: EPERM: operation not permitted, scandir 'C:\Config.Msi'
    Code: EPERM

Eas version
eas-cli/0.52.0 win32-x64 node-v16.15.0

Thank you in advance for your help!

Try closing editors, explorer, console, and any other applications that might keep that file open.

Thank you for your reply, I tried closing VSC and everything else on my PC and using command prompt but still had the same issue.

I’m not sure what’s happening, but something is looking in the root of your C:\ drive instead of stopping at the root of your project. There should not be anything trying to access C:\Config.Msi.

What directory were you in when you ran npx expo-env-info?

Do you have a package.json or package-lock.json or yarn.lockin the root of yourC:` drive?

Do you have a .git directory at the root of your project? Do you have a package.json file at the root of your project? And either a package-lock.json or yarn.lock?