Error after using 'npm start' or 'expo start'

ConfigUtils.configFilenameAsync is not a function

This is the error I’m getting after trying to use npm start

I rolled back to the 2.21.2 version in order to get past some earlier errors. Any ideas?

Expo CLI 2.21.2 environment info:
OS: Windows 10
Node: 12.13.0 - D:\nodejs\node.EXE
npm: 6.12.0 - D:\nodejs\npm.CMD

Okay. Simply reinstalling node and expo and then tweaking blacklist.js worked for me.

1 Like

Hello @arghantentua , what did you exactly do? And in what order?

Hi @arghantentua i tried reinstalling node and expo but having same issue can you elaborate on blacklist.js


Are you sure expo-cli installed correctly? Try running npm install -g expo-cli and check for errors similar to the ones under “Observed Behavior” on this bug report.

EDIT: The above bug has been closed because it was a duplicate of this one.

It seems that the version of libxmljs that is installed when you install expo-cli does not have an already compiled version for Windows, so npm tries to compile it. This fails if you do not have Visual Studio installed.

If you don’t want to/can’t install Visual Studio, you could try installing expo-cli version 3.5.0.

Otherwise you could install everything under Ubuntu on WSL. See this post and this one if you want to try that option.

Did’t worked for me

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.