Error after ejecting Expo


After I ejected my app from Managed to Bare workflow, the app was not longer working. I manages to fix some of the errors until I reached I point where I could not fix anything else (it was trying to read manifest version but manifest seems to be null.

I could not find any solution to this, so I tried creating a new Expo project (blank), ejecting and running in device, but this still fails. I followed the steps you tell but this doesn’t seem to be working. I gotta say this change (from Managed to Bare) is because the App I had, was working correctly a couple of days ago but suddenly stopped working for every iOS device.

As said, I followed every step documented and still fails. I hope you could help me with this issue.

Hey @bzaldua, to clarify are you saying that a new Bare project with no additional changes isn’t working for you?

Also could you further elaborate on what you mean by “suddenly stopped working”? The app crashed? Didn’t load?


Hi @adamjnav!

Yes sure! Just to keep in mind what happend.

Last week I had my app deployed with ExpoKit and suddenly the deployed iOS app (which until the day was working fine) suddenly stopped working. I mean, after closing the app from the background proccesses, I could not open it. It crashed as soon as it was opened.

So I decided to go with the Bare workflow as ExpoKit is deprecated. I did expo eject, I installed everything with pod and no error. But then, when launched with xCode I had a couple of errors but I managed to fix them until the manifest version null error. As far as I understand, with Bare workflow, the version that is set to the app is the one we set in xCode (correct me if I’m wrong), so I don’t really know why the manifest appears to be null

I managed to make it work but still don’t get what has happened. Either way, when I eject a project do I have to run expo publish or is there any other way to get the correct manifest without using expo cli?

Well. Managed to make it work

When we eject the project with admob the manifest.xml is configured with the app_id with “/”, just change it with the configuration app_id with “~” … Just place the app_id with “/” inside the tag but in the manifest.xml with “~” … Have a good year

Had the same error :smiley:

Thanks for the content sharing. It is really helpful for us.