Error: Activity not started

Hello,

  1. I have built an apk with eas build -p android --profile preview
  2. I installed expo-dev-client with expo install expo-dev-client
  3. I dragged and dropped the apk into my android simulator (Nexus 6 Tiramisu API 32). The installation was successful.
  4. In my app folder, I ran expo start --dev-client to start the app. The terminal tells me it worked fine. I have the mention:

Metro waiting on
exp+my-app-name://expo-development-client/?url=http%3A%2F%2F192.168.1.11%3A8081

  1. Then I press the a key to open the app on the Android device. A crash happen.

› Opening on Android…
› Opening exp+my-app-name://expo-development-client/?url=http%3A%2F%2F192.168.1.11%3A8081 on Nexus_6_API_Tiramisu
Couldn’t start project on Android: Error running adb: Error running app. Error: Activity not started, unable to resolve Intent { act=android.intent.action.VIEW dat=exp+paris-stars-map://expo-development-client/?url=http://192.168.1.11:8081 flg=0x10000000 }

  1. I tried to clean the cache with rm -rf ~/.expo/android-apk-cache. No effect.

How to fix this?

EDIT: I’ve managed to get a working build by using the --local command. Go figure.