Ejected Expo app stuck on splash screen in app-prodKernel-release.apk

Ejected Expo app stuck on splash screen in app-prodKernel-release.apk.
When I generate Debug APK it’s working also in the iOS platform everything working great.
Just face an issue when generating app-prodKernel-release.apk It’s stuck on the splash screen.

Android Studio Logcat:
2019-06-29 17:37:31.878 30480-30503/com.myApp.in E/GraphResponse: {HttpStatus: 400, errorCode: 100, subErrorCode: 33, errorType: GraphMethodException, errorMessage: Unsupported get request. Please read the Graph API documentation at https://developers.facebook.com/docs/graph-api}

I have same issue.

Did you solve this issue?

I have the same issue on android.

add “scheme” : “anything”, in your app.json .
then try again

Hi! I tried adding that scheme, but still ran into the same error. Would you be able to clarify this?

Are you using the Facebook SDK at all? The error message in the first comment seems to be about accessing the Facebook social graph.

No, but if I uninstall the expo-facebook package, I get other errors, even if I am not using the facebook api at all. This error also only shows up on production mode - if I switch the app to development mode, the app works fully and never crashes.

Hey, did you manage to solve your issue? I’m struggling with exactly the same problem and any help would be appreciated.