Ejected app path to app.manifest is wrong?

We started our app in the Managed workflow, needed to eject in order to use react-native-background-upload, and now I can’t get a production build to work right.

Stuff I’ve tried:

  • Building in Expo

When I use expo build:ios it builds in the Expo build service, but the fonts don’t appear to be there and it also doesn’t appear to have properly built/linked react-native-background-upload.

  • Building locally

I’ve also tried building via npx react-native run-ios --configuration Release, but I’m getting the following error:

Error reading the manifest file. Make sure the path '/Users/XXX/Documents/*app-directory*/ios/*app-name*/Supporting/app.manifest' is correct.

The weird thing is that the app-name in that path is the kebab-case version of the actual name? For example, if the actual folder name was MyApp, the path is /ios/*my-app*. I’ve done a fair amount of searching and can’t seem to find either where this is set or how to modify this?

1 Like