Ejected App Not loading the requested app (30.0.0)

Created a new expo project in 30.0.0.
Prepped app.json
cd ios
pod install
expo start
hit run in expo

“There was a problem loading the requested app. It looks liek you may be using a LAN URL. Make sure your device is on the same network as the server or try using a tunnel.”

And the url on the simulator is the same as the “Your app is running at …” url. “exp05baeabc46d3409da7e269233fb2b513://”

I have really run out of ideas how to get the standalone app to see the locally running process.

Same here,
hope someone have a solution

1 Like

Just a note that I’m having this exact same issue and posted about it here: Detached app seems to be loading from the wrong local address

1 Like

Thanks posting. It seems like an expo problem. Hoping to get some assistance today. Going to hop on the Slack and see if I can get this some attention.

same problem;

  • i created a really plain empty project with sdk30
  • eject
  • expo start
  • cd ios; pod install
  • open in xcode
  • start in ios simulator with pressing the button inside xcode “build and then run the current scheme”
  • on ios simulator the app starts, shows the splash-screen and then the error message “there was a problem loading the requested app…”

Sorry for this inconvenience :disappointed: We’ve just published ExpoKit v2.8.2 for ejected apps that should fix this issue, so you can try to update it in your Podfiles or just create a new app using expo init and then expo eject. Let me know if you have any questions :wink:

1 Like


Thanks so much for your hard work and I really appreciate the response!

I updated to 2.8.2 in the Podfile, cleared out my Pods, cleaned my project in XCode and rebuilt. However, I am still getting the same error when running the app.

Here’s what I’m running to launch expo:

Here’s what I’m getting when the app runs:

It seems like now it is loading the proper URL, but for some reason just not connecting.

Thanks again!


Looks like it solved the same problem for other users - see an issue on GitHub.
Could you try running Expo with --lan flag? It might be a problem with a tunnel :thinking:

Hm, dang!

I tried with --lan but still no go. Is there any other way to test the tunnel to verify if the issue is the tunnel or the app?

When I connect with --lan, how does the app know to use the lan URL? (It is still trying to connect through 9p-vpr.nickyhajal.mobile.exp.direct)

for me now everything is solved and working with creating a brand new expo-app:

expo init -t blank testsdk30
# after that it uses "expo": "^30.0.1",

I had some small issues after ejecting. But it could be solved by reinstalling modules:

rm -Rf ./node_modules

…then it worked

thanks to the expo-developers

1 Like

Hey Anil, could it be an issue with almost empty node_modules/react-native directory? It is the reason of errors in pod install as some RN podspecs cannot be found.
I encountered this problem as well and another workaround is to simply do yarn between expo init and expo eject.

1 Like

Just wanted to come back and say thank you for the hard work ExpoTeam. After updating npm global expo-cli and exp and creating a brand new expo app everything seems to be working as expected.

@tsapeta yes exactly; to verify - I again created a brand new project;
AFTER expo eject is finished the folder node_modules/react-native contains only the subfolder
node_modules/.bin which contains 6 symlinks

so when I do expo start I get the message
Error: React native is not installed. Please run `npm install` in your project directory

the solution --> as you described

1 Like

Something I realized is that mine is saying that: The experience you requested requires a newer version of the Expo Client app.

What does that mean exactly? I am running expo-cli 2.1.2 and the app is on ExpoKit 2.8.2

Is there something else I need to update? I’m going crazy trying to get this running again, haha.

@nickyhajal, unfortunately I’m not able to reproduce this issue, but I’d be happy to help if you provide more details like sdkVersion property of your app.json and the actual version of expo package in your node_modules :wink:

@nickyhajal I would try:

  1. Check npm global exp and expo-cli versions
    • npm -g list --depth=0
    • npm -g outdated
  2. Clear simulator to make sure it has newest version
  3. Check version of expo version in project

After I got everything up to date and restarted things it started working. This might not work but just thought I would try to help if I could.

1 Like

@tsapeta This is slightly off topic but wanted someone on the expo team to be aware.

You can see my note here: Build /bin/sh Error after Ejecting 30.0.0

It seemed like I needed exp installed to get my app to run even though the docs (https://docs.expo.io/versions/latest/expokit/eject.html) don’t mention it.

If you don’t have it, run npm install -g expo-cli to get our command line library.

If this is just a problem with my system or 30.0.0 and not 30.0.1 then feel free to disregard. It might be worth someone in the Expo team to just test this and if it is required add it to the docs to reduce any issues for others.

1 Like

Upgrading to the 2.8.3 release for iOS fixed this issue for me (just changed Podfile). Thank you Expo team!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.