eas version number wrong but expo version worked fine

eas-cli 5.2.0
node 16.4.0

I just started using eas build -p ios instead of expo build --ios and its generating with version 14 when my app.config.js says 19.0.0 under version."expo": { "entryPoint": "./app/app.tsx", "name": "VLD Sports", "slug": "parlay_mobile_vland", "version": "19.0.0",

Please help me as I really want to use eas build but until then I guess I will stick with expo build.

What would cause eas build to grab the wrong build number and expo build to pick the correct one?


Problem Solved. The app had ended up in bare mode again, so I modified the “CFBundleShortVersionString” field in the Info.PList file, then rebuilt its showing properly now.

Hi @chrisnorris070

If you did not intend to switch to the bare workflow, there are two ways you could approach this:

  1. Delete the android and ios directories, which basically switches you back to the managed workflow; or
  2. Run expo prebuild --clean to regenerate those native files to take into account changes to app.config.js

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.