EAS Updates fails on CI

Hello,

We have been using EAS services (Build and Submit) for our apps and it has been great thus far.

Recently, we decided to integrate EAS updates also, and the documentations were really helpful with setting it up. We tried publishing an update from our local environment and the update were getting published fine, but when we try publishing updates in a CI environment (Github Actions), EAS updates fails to resolve some packages (this doesn’t happen with Build and Submit).

The first time we encountered this error with the CI environment, it was dayjs that was failing to resolve, after replacing the implementation of dayjs in the app, it is failing to resolve uuid.

Any headway on this issue, because we can’t keep switching packages/implementation.

====================================================================

In your post, please share:

  • Whether you are bare or managed workflow: Bare workflow
  • Your eas-cli version: Latest (via expo github actions)
  • What you have tried so far (Tried changing implementation of packages it couldn’t resolve)