EAS update is not updating the app

Before posting your question, make sure you’ve read the documentation for both EAS Build & Submit.

If your Android or iOS build is failing- make sure you do your own research on the error message first before posting (this will give you a better understanding, and you might even find that someone else has already solved the issue!) It is not up to the Expo team to debug your project or build.

In your post, please share:

  • Whether you are bare or managed workflow : managed
  • Your eas-cli version : 0.52.0
  • What you have tried so far :
    changed the branch which was successful with expo publish, tried ‘expo publish’ but failed


after upgrading from expo publish, eas update is not updating client app anymore.
I followed the guide - Migrating from Classic Updates to EAS Update - Expo Documentation

Development environment :
Node: 14.18.2
react-native-cli: 2.0.1
react-native: 0.63.4
Expo CLI: 5.4.6
Expo SDK: 45.0.0
eas-cli: 0.52.0

I’m struggling this issue for a week. Can anyone please help to find out what I am missing?
(please feel free to ask me more detailed information)


  • I have changed the Expo organization’s owner
  • I have changed the Apple/Google developer organization’s owner

Thank you in advance