EAS Test Builds (detox headless) - build successful, all tests fail to run

I know that Expo & EAS support for Detox as E2E is early. I have read the docs and I have had experience with detox outside of Expo.

Important details

  • Bare workflow
  • Expo 46
  • Detox 20.1.1
  • Jest ^29
  • eas-build-pre-install.sh is setup
  • eas-build-on-success.sh is setup

The build itself is successful, and it states it starts the iOS simulator (only focused on iOS as starter since android has it’s own challenges) but then all tests are failing even though they are running locally as expected in both debug and release configurations.

Has anyone successfully run the detox tests from eas with the shell script hooks? Do I need to increase my timeout for CI?

Here’s the output of the build success hook where it states it exceeded the timeout to setup the detox environment

THANKS!

hi jenn! are you able to share a minimal reproducible example?

i just pulled the eas-tests-example repo and ran eas build -p ios -e test and it succeeded:

Also encountering the same issue (timeout while setting up) with a particular project running Detox (iOS) tests on EAS

Tried setting up Detox from scratch in a barebones Expo project, that works fine

Attempting to create a minimal reproduction but haven’t managed to narrow down the cause to anything in particular yet. Locally tests run fine, so just experimenting and hoping for a successful EAS build

@oops_jenn did you find any cause or solution?

@4lun Unfortunately I haven’t had time to spend on this in the last week. I’m hoping to circle back to it in another week or so.