EAS Submit - specify android package name

I just upgraded to latest eas-cli and my circle builds are failing to deploy to play store.

Previously we were able to specify the android package name with the eas submit command, this is now missing, and I can’t see in the docs where to add that in eas.json?

When trying to run eas submit locally i get the error:

Couldn't resolve the Android package.
    Error: Submission failed

I have tried also running eas build:configure.

Any help appreciated.



android package is not resolved from app.json for managed projects and from native code for bare.

One case that we seem to have regression on is for bare projects with multiple bundle identifiers/application id, we are planning to have autodetection of those values from the archive to avoid inconsistencies like that.

If you have manged project or bare with one applicationID/bundleIdentifier it should just work, if not there are 2 temporary workaround you can use

  • downgrade eas-cli
  • init empty managed project → update app.json values to match expected bundle identifier → submit using --path or --url option from directory of that project

Yes this is a bare project with multiple application id’s, we have downgraded to 0.25.0.



1 Like

Has this issue been resolved with eas-cli 0.37.0?

Yes, if you use local submit credentials it should work out of the box, if your submit credentials are managed by expo then you can specify applicationId in android submit profile and bundleIdentifier in ios submit profile (docs are not updated yet)

There is still one case we are working on, when you run build with --auto-submit bundleIdentifier/ applicationId is always known, but we are not using it for submit automatically

1 Like

Great, thanks @wkozyra

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.