eas submit android fails after change of expo account from personal to organization

I had built and submitted to the play store from my personal Expo account, but then realized I should create an organization in Expo so I could invite other developers. I changed the expo.owner in app.json to the organization and rebuilt, letting expo manage the keys, but when I submitted, the app bundle was signed with a different key. Note I did not change the slug. I am assuming the “Google Service Account Key” has nothing to do with the app signing, but I did use the same local file.

eas submit --platform android --latest

Google Service Account Key:
Key Source : local
Key Path : .json

Google Api Error: Invalid request - The Android App Bundle was signed with the wrong key.

Is it possible to switch back to the original key?
If not, what is the correct way to allow the organization key to be use by Google?

I can add that ios build and submit worked without any issues after switching to the org.


Hi @foodja

user1/slugA is treated as a completely different app to user2/slugA

You’d have to download user1/slugA’s credentials and then upload them to user2/slugA

You should be able to do this with eas credentials. You might have to set the owner back temporarily when fetching the old credentials and then set it to the organisation account when uploading again.
Otherwise I think you can also do it through the web interface.

Thanks! This worked perfectly. I did need to set the owner to the original to download the credentials, then set it to the organization to upload.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.