EAS service fails to build APK file but locally gradlew build succeeds


from saturday I am unable to build bare app using EAS build. We use 40 SDK bare app. The buider is not building apps from the code that was previously build using EAS without a problem. I checked documentation and tried all means, but they do not work, event cache clearing parameter on EAS config or build command, i might think it is related to EAS gradle cache as failure reason is always folowing

* What went wrong:
Could not determine the dependencies of task ':app:compileReleaseJavaWithJavac'.
> Could not resolve all dependencies for configuration ':app:releaseCompileClasspath'.
   > Problems reading data from Binary store in /tmp/gradle4072057243973384227.bin offset 186124 exists? true

If I run yarn android locally it builds app without any problem, but on EAS build it fails.

Proof that it works on yarn android and not works on EAS build

yarn run v1.15.2
warning package.json: "dependencies" has dependency "@types/react" with range "~16.9.35" that collides with a dependency in "devDependencies" of the same name with version "^16.8.19"
warning package.json: "dependencies" has dependency "@types/react-native" with range "~0.63.2" that collides with a dependency in "devDependencies" of the same name with version "^0.57.60"     
$ react-native run-android
info Running jetifier to migrate libraries to AndroidX. You can disable it using "--no-jetifier" flag.
Jetifier found 3034 file(s) to forward-jetify. Using 4 workers...
info Starting JS server...
* daemon not running; starting now at tcp:5037
* daemon started successfully
info Launching emulator...
info Successfully launched emulator.
info Installing the app...
Starting a Gradle Daemon, 1 incompatible and 1 stopped Daemons could not be reused, use --status for details

> Configure project :app

Installing unimodules:
 unimodules-core@6.0.0 from C:\Development\watalook-app\node_modules\@unimodules\core
 unimodules-react-native-adapter@5.7.0 from C:\Development\watalook-app\node_modules\@unimodules\react-native-adapter
 expo-splash-screen@0.10.2 from C:\Development\watalook-app\node_modules\expo-app-loading\node_modules\expo-splash-screen
 expo-application@2.4.1 from C:\Development\watalook-app\node_modules\expo-application
 expo-constants@9.3.5 from C:\Development\watalook-app\node_modules\expo-constants
 expo-contacts@8.6.0 from C:\Development\watalook-app\node_modules\expo-contacts
 expo-device@2.4.0 from C:\Development\watalook-app\node_modules\expo-device
 expo-error-recovery@1.4.0 from C:\Development\watalook-app\node_modules\expo-error-recovery
 expo-file-system@9.3.0 from C:\Development\watalook-app\node_modules\expo-file-system
 expo-firebase-analytics@2.6.0 from C:\Development\watalook-app\node_modules\expo-firebase-analytics
 expo-firebase-core@1.2.0 from C:\Development\watalook-app\node_modules\expo-firebase-core
 expo-font@8.4.0 from C:\Development\watalook-app\node_modules\expo-font
 expo-image-loader@1.3.0 from C:\Development\watalook-app\node_modules\expo-image-loader
 expo-image-manipulator@8.4.0 from C:\Development\watalook-app\node_modules\expo-image-manipulator
 expo-image-picker@9.2.1 from C:\Development\watalook-app\node_modules\expo-image-picker
 expo-in-app-purchases@10.1.1 from C:\Development\watalook-app\node_modules\expo-in-app-purchases
 expo-keep-awake@8.4.0 from C:\Development\watalook-app\node_modules\expo-keep-awake
 expo-linear-gradient@8.4.0 from C:\Development\watalook-app\node_modules\expo-linear-gradient
 expo-localization@9.1.0 from C:\Development\watalook-app\node_modules\expo-localization
 expo-location@10.0.0 from C:\Development\watalook-app\node_modules\expo-location
 expo-media-library@10.0.0 from C:\Development\watalook-app\node_modules\expo-media-library
 expo-notifications@0.8.2 from C:\Development\watalook-app\node_modules\expo-notifications
 expo-permissions@10.0.0 from C:\Development\watalook-app\node_modules\expo-permissions
 expo-secure-store@9.3.0 from C:\Development\watalook-app\node_modules\expo-secure-store
 expo-sqlite@8.5.0 from C:\Development\watalook-app\node_modules\expo-sqlite
 expo-updates@0.4.2 from C:\Development\watalook-app\node_modules\expo-updates
 expo-web-browser@8.6.0 from C:\Development\watalook-app\node_modules\expo-web-browser
 unimodules-app-loader@1.4.0 from C:\Development\watalook-app\node_modules\unimodules-app-loader
 unimodules-barcode-scanner-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-barcode-scanner-interface
 unimodules-camera-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-camera-interface
 unimodules-constants-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-constants-interface
 unimodules-face-detector-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-face-detector-interface
 unimodules-file-system-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-file-system-interface
 unimodules-font-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-font-interface
 unimodules-image-loader-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-image-loader-interface
 unimodules-permissions-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-permissions-interface
 unimodules-sensors-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-sensors-interface
 unimodules-task-manager-interface@5.4.0 from C:\Development\watalook-app\node_modules\unimodules-task-manager-interface

Found some duplicated unimodule packages. Installed the ones with the highest version number.
Make sure following dependencies of your project are resolving to one specific version:
 expo-constants, expo-splash-screen, expo-updates
WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed soon. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html

> Task :app:stripDebugDebugSymbols UP-TO-DATE
Compatible side by side NDK version was not found.

> Task :app:installDebug
10:42:11 V/ddms: execute: running am get-config
10:42:11 V/ddms: execute 'am get-config' on 'emulator-5554' : EOF hit. Read: -1
10:42:11 V/ddms: execute: returning
Installing APK 'app-debug.apk' on 'Pixel_2_API_30(AVD) - 11' for app:debug     
10:42:11 D/app-debug.apk: Uploading app-debug.apk onto device 'emulator-5554'
10:42:11 D/Device: Uploading file onto device 'emulator-5554'
10:42:11 D/ddms: Reading file permision of C:\Development\watalook-app\android\app\build\outputs\apk\debug\app-debug.apk as: rwx------
10:42:12 V/ddms: execute: running pm install -r -t "/data/local/tmp/app-debug.apk"
10:42:15 V/ddms: execute 'pm install -r -t "/data/local/tmp/app-debug.apk"' on 'emulator-5554' : EOF hit. Read: -1
10:42:15 V/ddms: execute: returning
10:42:15 V/ddms: execute: running rm "/data/local/tmp/app-debug.apk"
10:42:16 V/ddms: execute 'rm "/data/local/tmp/app-debug.apk"' on 'emulator-5554' : EOF hit. Read: -1
10:42:16 V/ddms: execute: returning
Installed on 1 device.

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.3/userguide/command_line_interface.html#sec:command_line_warnings

1124 actionable tasks: 3 executed, 1121 up-to-date
info Connecting to the development server...
info Starting the app on "emulator-5554"...
Starting: Intent { cmp=lt.pixinn.watalook/.MainActivity }
^Terminate batch job (Y/N)? ^C
PS C:\Development\watalook-app> eas build --platform android --profile debug                       
✔ Linked to project @mariuskra/watalook
Specifying "android.package" in app.json is deprecated for generic projects.
EAS Build depends only on the value in the native code. Please remove the deprecated configuration.
✔ Using remote Android credentials (Expo server)
Using Keystore ported from Expo Classic (expo-cli)
✔ Compressed project files 1m 54s (426 MB)
✔ Uploaded to EAS 1m 23s

Build details: https://expo.io/accounts/mariuskra/builds/9bc283f1-0525-4471-bcc5-1f3457a452ce

Waiting for build to complete. You can press Ctrl+C to exit.
✖ Build failed

🤖 Android build failed:
Gradle build failed with unknown error. Please see logs for the "Run gradlew" phase.
PS C:\Development\watalook-app> 

We do not cache anything between builds for android unless you configured it explicitly in eas.json. There is network cache but it’s only proxy for actual gradle/maven repositories not for the build artifacts.

  • Can you provide a link to the build?
  • Verify your gitignore file, maybe you are including some intermediate build results in your repo? -
  • Can you make a fresh clone of your project and run build on that?

Build link: Build Details — 65e7ef79-8778-4464-969d-6d767709f4b2 — @mariuskra/watalook — Expo

What i already tried: cleared gradle cache, then cloned project and opened breanch that previously had successfull EAS build, then pushed to EAS to build it and it failed, but it worked before.

Eas config is simple, nothing special is there also tried cache: {disable: true} option but no use.

There are more builds we tried all ways possible https://expo.io/accounts/mariuskra/projects/watalook/builds

This behaviour is from saturday. It worked well before. I just do not get where this “Problems reading data from Binary store in /tmp/gradle4072057243973384227.bin offset 186124 exists? true” is located and built.

We are using EAS for android build only