EAS Secrets Stopped working on Production


We have been using EAS services for our company app for over two months now and it has worked great.

We have published OTA updates twice with no issues.

Monday 08/23/2021 we did an OTA update which changed the version of the app.config.js (This is a first) along with other minor changes. Throughout Monday and most of Tuesday, everyone got the update and it worked just fine until around 4:30 PM EST Tuesday the 24th.

Suddenly, none of the API links stored as EAS Secrets were working. Since then, nobody has been able to use the app.

I’m certain the API links are the issue because the local version with a .env file works.

I’m not sure what to try here and there are multiple operations frozen due to this issue.

Please advise.

If the update was originally working for everyone, then I don’t believe EAS Secrets are the root cause here, but could be wrong. Were you testing with the exact same API links in your local version?

Hi Charlie,

We resolved the issue and yes it was not the secrets.

Thank you for the quick response!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.