eas login failing with ECONNRESET error


I’ve been having an issue the past two days with eas login and I’ve ruled out all of the obvious solutions by now. I’m using eas-cli/0.44.1 darwin-x64 node-v16.13.2 on the bare workflow. I’ve been logged into eas for some time now under my organization COO’s account, and yesterday we finally converted that individual account into an organization. I also took the chance to update my individual expo account’s email address and password. I invited my personal account to the new organization, and went to the terminal to run eas login (after making sure eas-cli was fully up to date). I got an “ECONNRESET” error, and got to work looking around for solutions. I did run EAS_DEBUG=true eas login and got the following output:

RequestError: read ECONNRESET
    at ClientRequest.<anonymous> (/Users/bkensey/.nvm/versions/node/v16.13.2/lib/node_modules/eas-cli/node_modules/got/dist/source/core/index.js:956:111)
    at Object.onceWrapper (node:events:510:26)
    at ClientRequest.emit (node:events:402:35)
    at ClientRequest.origin.emit (/Users/bkensey/.nvm/versions/node/v16.13.2/lib/node_modules/eas-cli/node_modules/@szmarczak/http-timer/dist/source/index.js:43:20)
    at TLSSocket.socketErrorListener (node:_http_client:447:9)
    at TLSSocket.emit (node:events:390:28)
    at emitErrorNT (node:internal/streams/destroy:157:8)
    at emitErrorCloseNT (node:internal/streams/destroy:122:3)
    at processTicksAndRejections (node:internal/process/task_queues:83:21)
    at TLSWrap.onStreamRead (node:internal/stream_base_commons:220:20)

While testing, I accidentally put the wrong password in and got the “failed login” message, so I believe my login is initially succeeding and then failing somehow before completion. I read on one of the ECONNRESET related posts that someone had luck using a VPN, so I’ve tried three different networks (home, cell hotspot and office) without luck. I don’t have vpn/proxy/etc software running on my laptop.

I’m stumped. Any ideas?

Something about typing out a problem can really help shake things loose, haha.I tried switching to node 14 and it succeeded. So the issue was using node v16.13.2. Should I file an issue?