EAS iOS build failed with bitcode error

Been working on my app for a few months and never had any issue, but today it started failing after a SDK upgrade (to 44). The simulator died with errors so I reverted back to SDK41 which I know worked yesterday.

Submit build, android passes but iOS fails

ld: could not reparse object file in bitcode bundle: ‘Invalid bitcode version (Producer: ‘1205.’ Reader: ‘1200.0.32.21_0’)’, using libLTO version ‘LLVM version 12.0.0, (clang-1200.0.32.21)’ for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

eas-cli/0.38.3 darwin-x64 node-v14.17.3

I saw a similar problem in september 2021 on the forums and the reply back then was that you had done some changes and that users were to re-build. Any advise from now?

the error you are seeing means that a library requires xcode 12.5 but you’re using xcode 12. if you update to sdk 44 the default image will use xcode 13 but if you have an image set explicitly it may not. also, this is likely caused by your eas-cli version – 0.38.3 is quite old and you should always update eas-cli to the latest.

Is it possible to use higher version of xcode without updating to sdk44 (when I tried, dependencies were broken and app could not launch in simulator)

you might want to follow this process to troubleshoot your issue: Troubleshooting build errors and crashes - Expo Documentation

you can update the xcode version using image in your build profile, this page shows the values you can use Build server infrastructure - Expo Documentation