EAS ios Build Fail: could not reparse object file in bitcode bundle: 'Invalid bitcode version'

โ€บ Linking   AppName ยป appslug

โŒ  ld: could not reparse object file in bitcode bundle: 'Invalid bitcode version (Producer: '1300.0.29.3.0_0' Reader: '1205.0.22.9_0')', using libLTO version 'LLVM version 12.0.5, (clang-1205.0.22.9)' for architecture arm64


โŒ  clang: error: linker command failed with exit code 1 (use -v to see invocation)

โ–ธ ** ARCHIVE FAILED **
โ–ธ The following build commands failed:
โ–ธ 	Ld /Users/expo/Library/Developer/Xcode/DerivedData/ThanksApp-cwswfwoyfulvjjcjhwdonwuwrdzc/Build/Intermediates.noindex/ArchiveIntermediates/ThanksApp/InstallationBuildProductsLocation/Applications/thanksapp.app/thanksapp normal
โ–ธ (1 failure)

Interestingly, the eas build with "developmentClient": true succeeds.

1 Like

I am having this same error

hi folks. please run your build again. we had published an updated package prebuilt framework using xcode 13 and that is incomatpible with xcode 12.5 bitcode format. we have rolled that update back.

1 Like

I am having this same error too
It worked well 2 days ago
But I have this error right now

please refer to the comment above: EAS ios Build Fail: could not reparse object file in bitcode bundle: 'Invalid bitcode version' - #3 by notbrent

There was no any changing on my end.
But it worked when I tried to build again
I hope there is no same issue on my next builds
Thank you

i described what went wrong in the comment linked above :slight_smile: it was an issue on our end - we published a version of a package that included a prebuilt xcframework that was only compatible with xcode 13.

I have a similar issue when installed react-native-unimodules in a react native cli project

Could not reparse object file in bitcode bundle: 'Invalid bitcode version (Producer: '1205.0.22.9.0_0' Reader: '1200.0.32.29_0')', using libLTO version 'LLVM version 12.0.0, (clang-1200.0.32.29)' for architecture arm64

I am using xcode 12.4 version, not sure I should upgrade it.

There is a new article saying we have to migrate from react-native-unimodules to expo

is anything related here?

you should update to xcode 12.5

Producer: โ€˜1205.0.22.9.0_0โ€™ Reader: โ€˜1200.0.32.29_0โ€™

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.