eas fast lane build fails. Image path, and pp/main.jsbundle does not exist. This must be a bug with

Hi,
My eas build fails at fast lane. How can I solve this issue?
Please help

❌  error: File /Users/expo/Library/Developer/Xcode/DerivedData/Kvadraturenvgs-fbkvfzvhuupevxdyaruzeggsigtl/Build/Intermediates.noindex/ArchiveIntermediates/Kvadraturenvgs/BuildProductsPath/Release-iphoneos/kvadraturen-vgs.app/main.jsbundle does not exist. This must be a bug with

546

❌ Metro encountered an error:
Unable to resolve module ../assets/Morten-rektor.jpg from /Users/expo/workingdir/build/app/screens/LedelsenStudent.js:

None of these files exist:
  * Morten-rektor.jpg
  * app/assets/Morten-rektor.jpg/index(.native|.ios.ts|.native.ts|.ts|.ios.tsx|.native.tsx|.tsx|.ios.js|.native.js|.js|.ios.jsx|.native.jsx|.jsx|.ios.json|.native.json|.json)
  18 |           <Image
  19 |             style={styles.rowImage}
> 20 |             source={require("../assets/Morten-rektor.jpg")}
     |                              ^
  21 |           />
  22 |           <View style={styles.rowText}>
  23 |             <AppText style={styles.name}>Morten Torkelsen</AppText>

Expo CLI 4.5.2 environment info:
System:
OS: macOS 11.4
Shell: 5.8 - /bin/zsh
Binaries:
Node: 14.17.0 - /usr/local/bin/node
npm: 7.20.6 - /usr/local/bin/npm
SDKs:
iOS SDK:
Platforms: iOS 14.5, DriverKit 20.4, macOS 11.3, tvOS 14.5, watchOS 7.4
Android SDK:
API Levels: 30
Build Tools: 30.0.3
System Images: android-30 | Google APIs Intel x86 Atom, android-30 | Google Play Intel x86 Atom
IDEs:
Android Studio: 4.2 AI-202.7660.26.42.7351085
Xcode: 12.5.1/12E507 - /usr/bin/xcodebuild
npmPackages:
expo: ~41.0.1 => 41.0.1
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-41.0.0.tar.gz => 0.63.2
react-native-web: ^0.17.1 => 0.17.1
npmGlobalPackages:
expo-cli: 4.5.2
Expo Workflow: managed

Hi

Can you check that the filename in Git is exactly the same as the name you’re trying to require(), including case.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.