`eas device:create` profile not shown in iOS Settings

I ran eas device:create and got the QR code.

I downloaded the file.

When I got to Settings, the button that is supposed to appear according to the instructions does not appear.

I’ve tried restarting my phone, “open from downloads”, save to Files, opening the ‘profile’ file from Files (nothing opens), force restarting settings, redownloading

I’m assume the instruction do not account for the file being save somewhere else, but I’m not sure where to save it.

In your post, please share:

  • Whether you are bare or managed workflow: managed
  • Your eas-cli version: eas-cli/0.33.1 darwin-x64 node-v14.17.0
  • What you have tried so far: above

SOLVED: I figured out that I need to open the QR code link in Safari on iOS, it doesn’t not work when opened in Chrome.

The Expo instructions should be updated to indicate this though so other users don’t run into this.

good catch, we’ll add a warning here if this page is opened on a mobile device in chrome