EAS Build Upload Issue

I am trying to do an android build with eas build command. But it’s always failing or stuck in uploading build files. Here’s the output of my eas build command.

❯ eas build
✔ Build for platforms › Android
✔ Linked to project @mesba/shajgoj
✔ Using remote Android credentials (Expo server)
✔ Compressed project files 1m 34s
✖ Uploading to EAS Build 5%
    HTTPError: Response code 400 (Bad Request)

I am trying since last 4/5 hours. It is failing always in this specific state with same error message.
I thought it’s my connection issue and tried to run build command from different network. Still same errors are happening. Can anyone confirm if it’s my issue or expo build servers are having any network issues?

This time for most projects I’m testing with is around 100 ms (for upload of the size around 100 MB), so I’m guessing that your repository must be huge. We don’t have explicit size limits in our config, so you must be hitting aws s3 limit of 5 GB

If you are not sure what is taking so much space you can verify with the same command that is used in eas-cli

git clone --depth 1  file:///home/user/path_to_existing_repo

cloned directory created by this command is packed inside tar.gz archive and uploaded to s3

Thanks for helping out. I already figured out the issue. Apparently in my android directory few large unnecessary Heap dump (.hprof) files were generated while I was debugging. I was trying to upload them too. Are there any guideline on which directories are important & which are not? It could be helpful to find out and clear out all extra clutters from our projects.

Default gitignore created by expo init should do the job for everything android/ios related, but it won’t work with sth like hprof because it’s not really android/ios specific file. In cases like that, you just need to be careful about what you committing, changes in native project made by expo-cli or eas-cli should be quite readable, so if you have some changes that you didn’t expect (especially some new files), you probably don’t want to commit that