eas build stuck on "Compressing project files"

Hi I’m having issues with running eas build locally on managed workflow. It get’s stuck on “Compressing project files” for ~30 minutes before failing with heap error:
Allocation failed - JavaScript heap **out** of memory

Any ideas on what might be causing this?

I have tried the following combinations of node and eas-cli versions without luck:
eas-cli/0.43.0 darwin-x64 node-v16.8.0
eas-cli/0.43.0 darwin-x64 node-v12.22.5
eas-cli/0.38.0 darwin-x64 node-v16.8.0
eas-cli/0.38.0 darwin-x64 node-v12.22.5


You could set an environment variable to increase the heap size. See if that helps:

initialize a new project and try it there. it seems like either your project is massive or something is happening during copying your project that is resulting in more files being added to the project (eg: if you try to archive a project within itself then you’ll have an error similar to the above). if you can share a reproducible example it would be helpful to understand better. you can also use eas build:inspect to manually archive, eg: eas build:inspect -p ios -s archive --output ~/Desktop/test


yeah same thing happens when running eas build:inspect -p ios -s archive --output ~/Desktop/test
I tried moving the project from the monorepo it resides in and that worked, compressed instantly. Thanks!

do you have any symlinks that point to the parent directories that might create a cycle?

I was able to reproduce issue with symlink cycle but I’m getting different error(Error: ENAMETOOLONG: name too long, scandir), so I’m not sure if it’s the same issue. it should be fixed in the next cli release [eas-cli] do not follow symlinks with fast-glob by wkozyra95 · Pull Request #891 · expo/eas-cli · GitHub

1 Like