EAS Build Prep for iOS Ad Hoc does not let me choose from all devices.

I made an ad hoc build a while ago, and was able to associate my two iOS devices with it no problem.

This morning, I added 5 more devices and went to make a new build, but EAS wont let me use a provisioning profile with them.

✔ All your registered devices are present in the Provisioning Profile. Would you like to reuse the profile? › Show devices and ask me again

Devices registered in the Provisioning Profile:
- 3880f67535aXXXXXXXXXXXXXXXXXX (iPad Pro (10.5 inch))

But I have 7 devices total in the apple portal:

But the EAS CLI cannot see those other 5.

So I tried to add the devices to the expo generated profile manually on the apple portal, which seems to change the internal ID of the profile, and if I run EAS again I get:

Provisioning profile (id: N78K8XXXXXX) does not exist in Apple Developer Portal
? Select devices for the ad hoc build: › - Space to select. Return to submit
- 3880f67535aXXXXXXXXXXXXXXXXXX (iPad Pro (10.5 inch))

Which then replaces the profile I added the devices to with a profile that only has the original two.

So how can I:

  • Force EAS to see the other devices I’ve added?
  • Or force EAS to use an existing provisioning profile on app portal?

I assumed this may be an API caching thing on Apple’s side, but it’s been 4 hours since I added those. So I’m pretty confused on how to make an ad hoc build with these devices in it.

Okay, turns out that you have to run:

eas device:create

In order for learn about new device IDs.

eas build will show you devices that expo already knows about, it will not automatically query the Apple portal for it.

1 Like

you should be able to choose the “Developer portal - import devices already registered on the Apple Developer Portal” option when running a build or eas device:create, it was added in july in [ENG-5622] allow importing devices from Apple Developer Portal by dsokal · Pull Request #1236 · expo/eas-cli · GitHub

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.