eas build --platform android error

I ran eas build --platform android but got this error:

[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] Execution failed for task ‘:app:bundleReleaseResources’.
[stderr] >
[stderr] A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
[stderr] > Android resource linking failed
[stderr] /home/expo/.gradle/caches/transforms-3/d9763394d7a2747fce682fa75f371244/transformed/core-1.7.0/res/values/values.xml:105:5-114:25: AAPT: error: resource android:attr/lStar not found.

Does anyone know what I need to fix?

same here

I’m also running into this issue. Did anyone find a fix?

What Expo SDK are you using?

This error seems to happen if you have some dependencies that are expecting Android SDK 31 and other dependencies are not compatible with that. Or something like that.

Expo SDK 46 uses Android SDK 31 by default.

I don’t know what my specific config was, especially since I’d ejected. I ended up just creating a new Expo app and copying my app code into that. It worked. (I also didn’t eject it this time. Can’t remember why I did last time, but it doesn’t seem to have been necessary.)

1 Like