eas build operation not permitted while compressing file

I am getting error while building android app by using eas build

My expo cli and eas cli both are updated

Hi @alokd07, does your local machine has Git setup? EAS uses Git has a version control system to upload a shallow copy of your project on EAS servers. If you gave git, it could be something is not committed in git.

Alternatively, if you are not using Git, or a different VSC, check this out: fyi/eas-vcs-workflow.md at main · expo/fyi · GitHub

1 Like

Hi @alokd07

The error means that Expo was unable to remove the specified temporary directory.
This could happen if you have an Antivirus app that was scanning that directory at the time that eas build was trying to remove the temporary directory. Maybe you can try telling your Antivirus not to scan C:\Users\alok7\AppData\Local\Temp\eas-cli-nodejs\?


I also tried the same but I am getting the same error.

Can you check the ownership/permissions of the files/directories under this path?


Are you able to delete them manually and then try building again?