EAS Build Failure After Adding expo-firebase-analytics

I would appreciate any help with this build error. It occurs after running eas build --profile development --platform all

Android error which occurs during the rungradlew phase:

> Task :app:processDebugMainManifest FAILED
See http://g.co/androidstudio/manifest-merger for more information about the manifest merger.
[stderr] /build/workingdir/build/android/app/src/debug/AndroidManifest.xml:14:13-88 Error:
[stderr] 	Attribute meta-data#org.unimodules.core.AppLoader#react-native-headless@value value=(org.unimodules.adapters.react.apploader.RNHeadlessAppLoader) from [:unimodules-react-native-adapter] AndroidManifest.xml:14:13-88
[stderr] 	is also present at [:expo-modules-core] AndroidManifest.xml:14:13-86 value=(expo.modules.adapters.react.apploader.RNHeadlessAppLoader).
[stderr] 	Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:12:9-14:91 to override.
> Task :expo-dev-launcher:generateDebugRFile
[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] Execution failed for task ':app:processDebugMainManifest'.
[stderr] > Manifest merger failed : Attribute meta-data#org.unimodules.core.AppLoader#react-native-headless@value value=(org.unimodules.adapters.react.apploader.RNHeadlessAppLoader) from [:unimodules-react-native-adapter] AndroidManifest.xml:14:13-88
[stderr]   	is also present at [:expo-modules-core] AndroidManifest.xml:14:13-86 value=(expo.modules.adapters.react.apploader.RNHeadlessAppLoader).
[stderr]   	Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:12:9-14:91 to override.
[stderr] * Try:
[stderr] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[stderr] * Get more help at https://help.gradle.org
[stderr] BUILD FAILED in 1m 47s
Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.8/userguide/command_line_interface.html#sec:command_line_warnings
335 actionable tasks: 335 executed
Error: Gradle build failed with unknown error. Please see logs for the "Run gradlew" phase.

iOS error which occurs during the install pods phase:

Found some duplicated unimodule packages. Installed the ones with the highest version number.
Make sure following dependencies of your project are resolving to one specific version:
 expo-constants, expo-modules-core, expo-updates-interface
Using firebase.json from '/Users/expo/workingdir/build/firebase.json'
Adding a custom script phase for Pod RNFBApp: [RNFB] Core Configuration
Auto-linking React Native modules for target `Momken`: RNCAsyncStorage, RNDateTimePicker, RNFBApp, RNFBAuth, RNGestureHandler, RNPurchases, RNReanimated, RNSVG, RNScreens, expo-dev-client, expo-dev-launcher, expo-dev-menu, expo-dev-menu-interface, react-native-netinfo, and react-native-safe-area-context
Analyzing dependencies
Fetching podspec for `DoubleConversion` from `../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec`
Fetching podspec for `Folly` from `../node_modules/react-native/third-party-podspecs/Folly.podspec`
Fetching podspec for `glog` from `../node_modules/react-native/third-party-podspecs/glog.podspec`
Adding spec repo `trunk` with CDN `https://cdn.cocoapods.org/`
CocoaPods 1.11.2 is available.
To update use: `sudo gem install cocoapods`
For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.11.2
[!] CocoaPods could not find compatible versions for pod "Firebase/CoreOnly":
  In snapshot (Podfile.lock):
    Firebase/CoreOnly (= 7.6.0, ~> 7.6.0)
  In Podfile:
    EXFirebaseAnalytics (from `../node_modules/expo-firebase-analytics/ios`) was resolved to 5.0.3, which depends on
      Firebase/Core (= 7.7.0) was resolved to 7.7.0, which depends on
        Firebase/CoreOnly (= 7.7.0)
    RNFBApp (from `../node_modules/@react-native-firebase/app`) was resolved to 10.8.1, which depends on
      Firebase/CoreOnly (~> 7.6.0)
    RNFBAuth (from `../node_modules/@react-native-firebase/auth`) was resolved to 10.8.1, which depends on
      Firebase/Auth (~> 7.6.0) was resolved to 7.6.0, which depends on
        Firebase/CoreOnly (= 7.6.0)
You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * changed the constraints of dependency `Firebase/CoreOnly` inside your development pod `EXFirebaseAnalytics`.
   You should run `pod update Firebase/CoreOnly` to apply changes you've made.
[stderr] [!] `<PBXResourcesBuildPhase UUID=`13B07F8E1A680F5B00A75B9A`>` attempted to initialize an object with an unknown UUID. `94B39D9CD4354C35AD0AC40C` for attribute: `files`. This can be the result of a merge and the unknown UUID is being discarded.
Error: Compatible version of some pods could not be resolved.
You are seeing this error because either:
  - Versions in the Podfile.lock cached by EAS do not match required values for some of the libraries, it can be triggered when upgrading Expo SDK or any other library with native code. To fix that add "cache.key" field (it can be set to any value) in eas.json to invalidate the cache.
  - Some of your npm packages have native code that depend on different versions of the same pod. Please see logs for more info.

This occurs after adding expo-firebase-analytics and attempting to build a development client. I have two google-services files named: 1- google-services-android.json 2- google-services-ios.json

Here’s my app.json

{
  "expo": {
    "name": "Momken",
    "slug": "momken_test_1",
    "version": "1.1.0",
    "orientation": "portrait",
    "icon": "./assets/Momken.png",
    "plugins": [
      [
        "expo-notifications",
        {
          "icon": "./images/notification_icon.png",
          "color": "#ffffff",
          "mode": "production"
        }
      ]
    ],
    "splash": {
      "image": "./images/splash_image1.png",
      "resizeMode": "cover"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "googleServicesFile": "./google-services-ios.plist",
      "infoPlist": {
        "UIBackgroundModes": ["remote-notification"],
        "CFBundleAllowMixedLocalizations": true
      },
      "supportsTablet": false,
      "bundleIdentifier": "com.ahmedhoranieh",
      "config": {
        "googleMobileAdsAppId": "***********"
      }

    },
    "android": {
      "googleServicesFile": "./google-services-android.json",
      "package": "com.ahmedhoranieh.momken_test_1",
      "config": {
        "googleMobileAdsAppId": "***********"
      }
      
    },
    "locales": {
      "en": "./languages/english.json",
      "ar": "./languages/arabic.json"
    },
    "web": {
      "favicon": "./assets/favicon.png"
    },
    "facebookAppId": "*********",
    "facebookDisplayName": "مُمْكِنْ"
  }
}

and here’s my packages.json

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "postinstall": "npx jetify"
  },
  "dependencies": {
    "@expo/vector-icons": "^12.0.0",
    "@fortawesome/fontawesome-svg-core": "^1.2.34",
    "@fortawesome/free-brands-svg-icons": "^5.15.2",
    "@fortawesome/free-regular-svg-icons": "^5.15.2",
    "@fortawesome/free-solid-svg-icons": "^5.15.2",
    "@fortawesome/react-fontawesome": "^0.1.14",
    "@freakycoder/react-native-bounceable": "^0.2.5",
    "@react-native-async-storage/async-storage": "~1.15.0",
    "@react-native-community/datetimepicker": "3.5.2",
    "@react-native-community/netinfo": "^6.0.2",
    "@react-native-firebase/app": "^10.8.0",
    "@react-native-firebase/auth": "^10.8.0",
    "@react-navigation/bottom-tabs": "^6.0.8",
    "@react-navigation/native": "^6.0.5",
    "@react-navigation/stack": "^6.0.10",
    "algoliasearch": "^4.10.5",
    "expo": "~42.0.1",
    "expo-ads-admob": "~10.1.2",
    "expo-barcode-scanner": "~10.2.2",
    "expo-dev-client": "^0.6.2",
    "expo-facebook": "~11.3.1",
    "expo-file-system": "~11.1.3",
    "expo-firebase-analytics": "^5.0.3",
    "expo-firebase-core": "^4.0.3",
    "expo-google-app-auth": "^8.2.2",
    "expo-in-app-purchases": "^11.0.1",
    "expo-notifications": "^0.12.3",
    "expo-sharing": "~9.2.1",
    "expo-status-bar": "~1.0.4",
    "expo-task-manager": "^9.2.2",
    "firebase": "8.2.3",
    "jetifier": "^2.0.0",
    "lodash": "^4.17.21",
    "moment": "^2.29.1",
    "npm": "^6.14.15",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-instantsearch-native": "^6.12.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz",
    "react-native-calendars": "^1.1267.0",
    "react-native-chart-kit": "^6.11.0",
    "react-native-circular-progress": "^1.3.7",
    "react-native-flash-message": "^0.2.0",
    "react-native-keyboard-aware-scroll-view": "^0.9.4",
    "react-native-modal": "^11.7.0",
    "react-native-multicolor-progress-bar": "^1.0.3",
    "react-native-purchases": "^4.3.1",
    "react-native-rounded-checkbox": "^0.3.3",
    "react-native-safe-area-context": "3.2.0",
    "react-native-segmented-picker": "^2.0.2",
    "react-native-simple-dialogs": "^1.4.0",
    "react-native-size-matters": "^0.4.0",
    "react-native-snap-carousel": "^3.9.1",
    "react-native-svg": "^12.1.1",
    "react-native-three-dots-loader": "^1.0.1",
    "react-native-web": "~0.13.12",
    "xlsx": "^0.17.2"
  },
  "devDependencies": {
    "@babel/core": "~7.9.0"
  },
  "private": true
}