EAS build fails when using associatedDomains (ios, managed workflow)


We’re trying to use associatedDomains in expo config:

"associatedDomains": ["applinks:jjfoodservice.com"]

But the build fails with the following error:

❌  JJFoodservice/JJFoodservice: Provisioning Profile "*[expo] com.jjfoodservice.apollo AppStore 2020-11-12T12:56:47.831Z" does not support the Associated Domains capability.
❌  JJFoodservice/JJFoodservice: Entitlements file defines the value "com.apple.developer.associated-domains" which is not registered for profile "*[expo] com.jjfoodservice.apollo AppStore 2020-11-12T12:56:47.831Z".

The build that failed:

Since we use the provisioning profile what expo created it already has the associated-domains capabaility - which we double checked on Apple Developer portal, and it’s there.

Found an old issue where eas-cli had a bug with associated-domains, but that seems to be fixed - and we’re using latest eas: eas-cli/2.6.0 darwin-arm64 node-v16.17.1

Tried to find any similar issue, but all pointing to check the provisioning profile that it has the associated-domains capability enabled.

Could this be related to the current reduced service? Expo Status - Some assets may be missing from EAS Update

Could you point us to the right direction?


The error you’re experiencing should not be related to that service warning.

I know the provisioning profile appears to be OK, but wondering if you can try deleting the profile from developer.apple.com and from EAS and seeing what happens when you then let EAS Build create it fresh again.

Deleted the provisioning profile from Apple Dev portal, also removed from expo (Expo…)

But when re-run the eas build - it’s still trying to use that non-existent provisioning profile and throwing the same error as before:

Does EAS servers cache these files? Can the cache cleared somehow?

Was able to recreate the provisioning profile using expo build

✔ Will you provide your own Apple Provisioning Profile? › Let Expo handle the process
✔ Created Apple provisioning profile
Successfully created Provisioning Profile

But seems like the EAS build still trying to use the old profile: