EAS Build fails when building custom dev client for iOS simulator

I’m trying to build a custom development client for the iOS simulator because I want to add a plugin but I keep getting an error about a missing specification when it is installing the pods. Can you see what the issue is? I have a managed flow with expo-yarn-workspaces. I tried adding expo-updates to my dependencies but that didn’t help.
Heres the error message:

Installing pods
Installing unimodules:
 unimodules-core@7.1.2 from ../node_modules/react-native-unimodules/node_modules/@unimodules/core/ios
 unimodules-react-native-adapter@6.3.7 from ../node_modules/react-native-unimodules/node_modules/@unimodules/react-native-adapter/ios
Auto-linking React Native modules for target `Omnicharge`: RNCAsyncStorage, RNGestureHandler, RNReanimated, RNScreens, expo-dev-client, expo-dev-launcher, expo-dev-menu, expo-dev-menu-interface, and react-native-safe-area-context
Analyzing dependencies
Fetching podspec for `DoubleConversion` from `../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec`
Fetching podspec for `Folly` from `../node_modules/react-native/third-party-podspecs/Folly.podspec`
Fetching podspec for `glog` from `../node_modules/react-native/third-party-podspecs/glog.podspec`
Adding spec repo `trunk` with CDN `https://cdn.cocoapods.org/`
CocoaPods 1.11.2 is available.
To update use: `sudo gem install cocoapods`
For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.11.2
[!] Unable to find a specification for `EXUpdatesInterface` depended upon by `expo-dev-launcher`
You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.
[stderr] [!] `<PBXResourcesBuildPhase UUID=`13B07F8E1A680F5B00A75B9A`>` attempted to initialize an object with an unknown UUID. `A283989FC7B24C9D80A1E880` for attribute: `files`. This can be the result of a merge and the unknown UUID is being discarded.

So specifically: "Unable to find a specification for EXUpdatesInterface depended upon by expo-dev-launcher"
Since I am using the managed flow I’m not using Xcode or Android studio but the suggestions after the error message seems to refer how to fix it if I was doing the bare workflow?

What do you think I’m missing? Do you need more information?

hi- what version of expo-dev-client are you using? And this is inside a monorepo? You might need to add these packages (aka "expo-updates-interface" and possibly others) to your symlinks array

Hey, I’m using version 0.5.1. The app is inside a monorepo but it’s the only React Native app in the monorepo if that makes a difference. I tried adding some things to a symlink array like in Cedrics eas yarn monorepo but then I got warnings about duplicated dependencies so maybe symlinks are only useful if you have multiple React Native apps in your monorepo?

Hi again. I solved it by adding all the dependencies to my symlink array that was in Cedrics monorepo example, thanks for pointing me in that direction again.

1 Like

nice! thanks for following up here