EAS Build fails on for iOS with "Error: Failed to find Electron ..."

I was able to successfully create a build for iOS 12 days ago. But today I made a quick change just to a translation file (not a code change) and I get this error on the EAS build:

Error: Failed to find Electron v1.8.8 for darwin-arm64 at https://github.com/electron/electron/releases/download/v1.8.8/electron-v1.8.8-darwin-arm64.zip

Android builds fine.

I’ve tried different versions of node locally. Not sure if this would affect the build on EAS, but that is the only thing I can think of to try.

  • Managed workflow
  • eas-cli/3.8.1 darwin-arm64 node-v18.15.0 (tried v16.13.2, v17.3.1)

We are slowlly migrating users to M1/M2 by default, and it looks like sth in your build trying to download electron for M1 that does not exits. You can specify "resourceClass": "intel-medium" in your eas.json to force intel

3 Likes

Awesome. That worked. Thank you so much for the quick response!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.