EAS build fails on Fastlane step within NX monorepo setup

Hi there,

I’ve started building an Expo app about a month ago and decided yesterday to migrate it to a NX monorepo setup I have to be able to share code I need for related projects.

Before migrating, I managed to easily push it to EAS and have it built and sent to the Testflight app.

However, after migrating I keep getting errors on the build. The error from the downloaded XCode log reads:

error Cannot resolve ./dist/base/default.
Error: Cannot resolve ./dist/base/default
    at /Users/expo/workingdir/build/node_modules/@nrwl/expo/plugins/metro-resolver.js:31:15

My app is using the managed workflow and my eas-cli version is 3.6.0.

Here is a link to the iOS build on EAS.

I am wondering whether this is related to the app living in the monorepo but I’ve followed all instructions on how to set it up correctly. Plus, I would assume that if I run the eas build command from the app level folder it shouldn’t be any different.

What I’ve tried so far:

  1. running eas build from both the root and the app folder within the monorepo
  2. making changes to metro.config.js according to what I could find online
  3. Tried finding similar issues but couldn’t find related ones.

Would love some input on this!