Eas build fails for ios and android - UpdatesDevLauncherController

SDK 45
eas 0.57.0
Hello, Eas build fails with the given errors shown in the pictures. expo run:ios and expo run:android also fails with the same errors, but when I comment the given lines of code in the UpdatesDevLauncherController file expo run:ios and android succeded, but eas build still fails for both platforms with the same error. Tried different versions of expo-updates still getting the same error.

Hi @radjab, in your project, can you expo doctor and please share the output here?

I get this, but I still get the same error even if I use the 3.1.1 version, and with the 3.1.1 version, I cannot make it run locally.

Some dependencies are incompatible with the installed expo package version:
 - @sentry/react-native - expected version: ^3.1.1 - actual version installed: 4.2.3

It seems you’ll the version of @sentry/react-native is not compatible with Expo SDK version your project is using and expo-updates is an additional dependency that is required when installing @sentry/react-native as mentioned in the docs here.

I’d suggest deleting package-lock.json or yarn.lock file in your Expo project and then run expo doctor --fix-dependencies which will fix incompatible dependency versions.

I already tried doctor --fix-dependencies, and deleting the package-lock.json still did not work. I built them locally with Xcode and Gradle. Finally upgrading to SDK 46 fixed the problem with EAS for me.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.