EAS build fails for Android: Execution failed for task ':app:mergeReleaseNativeLibs'

@isthejack Is your yarn.lock or package-lock.json checked in?

1 Like

@wodin Yes - How the same commit can be built a few days ago and now it’s failing?

It worked. Thanks!

@isthejack, according to this message in the issue that Brent linked to the build servers automatically install a few libraries. If you do not specify those libraries in your dependencies then the build servers will install basically the latest available version. So it seems that when you built your app previously the build servers used a slightly older version of reanimated. When you try to build now they use a slightly newer version which causes this problem.

1 Like

I see. Thank you for the explanation @wodin. Cheers!

1 Like

I did npm install react-native-reanimated@2.2.0 and then tried to build. It’s still failing. What am I doing wrong?

npm install doesn’t actually install the exact version. open your package.json and change the react-native-reanimated version to “2.2.0” (not “^2.2.0” or “~2.2.0”) then run npm install again

2 Likes

Thank you it did work!